# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$"
test_str = ("stage.shop.limmex.com\n"
"stage.shop.limmex.de\n"
"admin.limmex.de\n"
"admin.limmex.de/alarm/436761952161800\n"
"admin.limmex.de/alarm/4367619270344\n"
"admin.limmex.de/alarm/43676192703445\n"
"admin.limmex.de/alarm/353532064882314\n"
"admin.limmex.de/alarm/356051080526968\n"
"admin.limmex.de/status\n"
"www.limmex.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.