import Foundation
let pattern = #"(.*)\s[A-Z]{2,}[0-9]{2}.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)