using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^£[0-9]+\.[0-9]{2}$";
string input = @"£15.05
£1500.05
£1500.005
£1500.5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}