package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^£[0-9]+\.[0-9]{2}$`)
var str = `£15.05
£1500.05
£1500.005
£1500.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}