$re = '/^£[0-9]+\.[0-9]{2}$/m';
$str = '£15.05
£1500.05
£1500.005
£1500.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);