#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<[^>]*>)?(accessed(?:\s*\:?\s*| on ))((?:[0-2]?[0-9]?|30|31)(?:st|nd|rd|th)?)(?:<\/[^>]*>)?([\.\-\/ ])(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?|[1-9]|1[012])([\.\-\/ ])(?:<[^>]*>)?(20\d{2})(?:<\/[^>]*>)?"
Local $sString = "<note>accessed 13</note> March <year>2022</year>" & @CRLF & _
"<note>accessed 13th</note> March <year>2022</year>" & @CRLF & _
" <note>accessed 8</note> April <year>2022</year>." & @CRLF & _
"accessed 21st February 2020" & @CRLF & _
"accessed 32 Febr 2022" & @CRLF & _
"accessed 32 February 2022" & @CRLF & _
"accessed 30 February 202" & @CRLF & _
"accessed 30 January 2022" & @CRLF & _
"accessed 30 Jan 2022" & @CRLF & _
"accessed 30 February 2022" & @CRLF & _
"accessed 30 Feb 2022" & @CRLF & _
"accessed: 30 March 2022" & @CRLF & _
"accessed on 30 Mar 2022" & @CRLF & _
"accessed 30 April 2022" & @CRLF & _
"accessed 30 Apr 2022" & @CRLF & _
"accessed 30 May 2022" & @CRLF & _
"accessed 30 June 2022" & @CRLF & _
"accessed 30 Jun 2022" & @CRLF & _
"accessed 30 July 2022" & @CRLF & _
"accessed 30 Jul 2022" & @CRLF & _
"accessed 30 August 2022" & @CRLF & _
"accessed 30 Aug 2022" & @CRLF & _
"accessed 30 September 2022" & @CRLF & _
"accessed 30 Sep 2022" & @CRLF & _
"accessed 30 October 2022" & @CRLF & _
"accessed 30 Oct 2022" & @CRLF & _
"accessed 30 November 2022" & @CRLF & _
"accessed 30 Nov 2022" & @CRLF & _
"accessed 30 December 2022" & @CRLF & _
"accessed 30 Dec 2022" & @CRLF & _
"" & @CRLF & _
"accessed on 30.12.2022" & @CRLF & _
"accessed on 30.13.2022" & @CRLF & _
"accessed on 34.12.2022" & @CRLF & _
"accessed on 30.12.2023" & @CRLF & _
"accessed on 30.15.2022" & @CRLF & _
"accessed on 01.12.2022" & @CRLF & _
"accessed on 41.12.2092" & @CRLF & _
"" & @CRLF & _
"accessed on 30-12-2022" & @CRLF & _
"accessed on 30-13-2022" & @CRLF & _
"accessed on 34-12-2022" & @CRLF & _
"accessed :30-12-2023" & @CRLF & _
"accessed :30-15-2022" & @CRLF & _
"accessed :01-12-2022" & @CRLF & _
"accessed :41-12-2092" & @CRLF & _
"" & @CRLF & _
"accessed : 30/12/2022" & @CRLF & _
"accessed : 30/13/2022" & @CRLF & _
"accessed :34/12/2022" & @CRLF & _
"accessed :30/12/2023" & @CRLF & _
"accessed : 30/15/2022" & @CRLF & _
"accessed 01/12/2022" & @CRLF & _
"accessed 41/12/2092" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")