#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^A$[.\n]*?^XYZ$"
Local $sString = "A" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"XYZ" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"A" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"A" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"A" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"XYZ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")