package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^A$[.\n]*?^XYZ$`)
var str = `A
.
.
XYZ
.
.
A
.
.
A
.
.
A
.
.
XYZ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}