package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,\s=]+)\s*=\s*(?|'([^']*)'|(\S+))`)
var str = `col1 = 'Test String' , col2= 'Next Test String',col3='Last Text String', col4=37`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}