package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^31\.13\.24\.0$|^31\.13\.24\.1$`)
var str = `31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}