import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(?!=).+:";
final String string = "SELECT name, @age:=(age+5), address, @total:=(total+1)\n"
+ "FROM `users`\n"
+ "WHERE\n"
+ "id = :id:\n"
+ "name = :LOWER(name):\n"
+ "date = :strftime('%Y-%m %H:%i:%s', updated_at):\n"
+ "hash = :MD5(concat(status, salt)):\n"
+ "desc = :hash=foo:\n"
+ "ORDER BY name ASC\n\n"
+ "SELECT mytable.id, DATE_FORMAT(mytable.created_at,'%d/%m/%Y %H:%i:%s') AS created_at_uk FROM mytable WHERE mytable.id = ?\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}