#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!\s*#\w+\s*<\/a>)(#(\w+))"
Local $sString = "#hashtag <a target="_blank" class="removable-mention" data-mentionid="1" href="/useroverview/1/Henkjan%20de%20Krijger" contenteditable="false">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag" & @CRLF & _
"" & @CRLF & _
"#hashtag "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")