using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\s*#\w+\s*<\/a>)(#(\w+))";
string input = @"#hashtag <a target=""_blank"" class=""removable-mention"" data-mentionid=""1"" href=""/useroverview/1/Henkjan%20de%20Krijger"" contenteditable=""false"">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag
#hashtag ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}