const regex = /(?!\s*#\w+\s*<\/a>)(#(\w+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\s*#\\w+\\s*<\\\/a>)(#(\\w+))', 'g')
const str = `#hashtag <a target="_blank" class="removable-mention" data-mentionid="1" href="/useroverview/1/Henkjan%20de%20Krijger" contenteditable="false">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag
#hashtag `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}