$re = '/(?!\s*#\w+\s*<\/a>)(#(\w+))/';
$str = '#hashtag <a target="_blank" class="removable-mention" data-mentionid="1" href="/useroverview/1/Henkjan%20de%20Krijger" contenteditable="false">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag
#hashtag ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);