import Foundation
let pattern = ##"(?!\s*#\w+\s*<\/a>)(#(\w+))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#hashtag <a target="_blank" class="removable-mention" data-mentionid="1" href="/useroverview/1/Henkjan%20de%20Krijger" contenteditable="false">Henkjan de Krijger</a>#hashtag <a><br> #hashtag <a>#notahashtag</a>#hashtag
#hashtag
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)