import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(UNIQUE|\\\"(?:response|someothedata|otherdata|somedata)\\\")";
final String string = "{ \"name\": \"abc\", \"response\": { \"postback\": \"UNIQUE-a651-95e4834b63cc\" } }\n"
+ "{ \"name\": \"abc\", \"response\": { \"postback\": \"a651-95e4834b63cc\" } }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}