#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\brs\W*?(\d{1,7}(?:,\d+)*)\b(?:\s*?(?:-|to)\s*?(?:\brs\b\W*?)?(\d{1,7}(?:,\d+)*)\b)?"
Local $sString = "The price was Rs.1000" & @CRLF & _
"The price was Rs 1000" & @CRLF & _
"The price was Rs.1000 - 5000" & @CRLF & _
"The price was Rs.1000 - Rs.5000" & @CRLF & _
"The price was Rs.50,000" & @CRLF & _
"The price was Rs 1,25,000 - Rs 2,45,000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")