$re = '/\brs\W*?(\d{1,7}(?:,\d+)*)\b(?:\s*?(?:-|to)\s*?(?:\brs\b\W*?)?(\d{1,7}(?:,\d+)*)\b)?/i';
$str = 'The price was Rs.1000
The price was Rs 1000
The price was Rs.1000 - 5000
The price was Rs.1000 - Rs.5000
The price was Rs.50,000
The price was Rs 1,25,000 - Rs 2,45,000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);