use strict;
my $str = 'Some description art.nr: 4457 72 1x ACOUCH 90X200 NICE GRAY (3 colli) 1x matras 85x205x12 2x matras 80x190x11 Some specs 14x Premium otherproduct 90x200x23 HR34';
my $regex = qr~(?=\b\d+[xX]\b)~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";