$re = '/\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]/m';
$str = '[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]';
$subst = "{{<template>|$1|$2}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;