re = /(?<=%%\[(\s|.)*)\s*(?=(\s|.)*\]%%)/m
str = '
set Lorem ipsum
%%[
set @truth = \'this is amp\'
IF @truth == \'this is amp\' THEN
set @response = \'amp rocks\'
ELSE
set @response = \'️...\'
ENDIF
]%%
set Lorem ipsum
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end