using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!000|666|9\d\d)\d{3}-(?!00)\d\d-(?!(.)\1{3})\d{4}$";
string input = @"104-50-0034
000-12-1234
123-00-5432
123-45-6789
1234-56-7890
1234-567-8901
123-45-6666
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}