$re = '/^(?!000|666|9\d\d)\d{3}-(?!00)\d\d-(?!(.)\1{3})\d{4}$/m';
$str = '104-50-0034
000-12-1234
123-00-5432
123-45-6789
1234-56-7890
1234-567-8901
123-45-6666
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);