import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*?|\\G)(\\d\\d\\.\\d\\d\\.(?:\\d{4})?)|.*";
final String string = "BEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;ENCODING=QUOTED-PRINTABLE;CHARSET=UTF-8:18.07.=0A14.08.=0A15.09.=0A15.10.=\n"
+ "=0A13.11.=0A13.12.=0A12.01.=0A03.02. Grippe=0A06.03.=0A04.04.2015=0A0=\n"
+ "5.05.2015=0A03.06.2015=0A03.07.2015=0A02.08.2015=0A30.08.2015=0A28.09=\n"
+ "17.11.2017=0A\n"
+ "DCREATED:20171118T095601\n"
+ "X-IRMC-LUID:150\n"
+ "END:VNOTE";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}