use strict;
my $str = '1922-08-22T05:00:00Z';
my $regex = qr/(-?(?:[1-9][0-9]*)?[0-9]{4})-(1[0-2]|0[1-9])-(3[01]|0[1-9]|[12][0-9])T(2[0-3]|[01][0-9]):([0-5][0-9]):([0-5][0-9])(\\.[0-9]+)?(Z)?/mp;
my $subst = '$1-$2-$3 $4:$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";