\s*any whitespace character, repeated any number of times
ALERT:the literal text ALERT: (case insensitive) Non-Capturing Group(?:Rs\.?|INR) Rsthe literal text Rs (case insensitive) \.?optionally matches the literal . (4610 / 568 / 2E16)
INRthe literal text INR (case insensitive) Non-Capturing Group(?:\s*) \s*any whitespace character, repeated any number of times
Group 1([0-9,]+(?:\.[0-9]+)?|\.[0-9]+) 1st Alternative[0-9,]+(?:\.[0-9]+)? +matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:\.[0-9]+)? ?repeats the group contents below at most once:
\.the literal . (4610 / 568 / 2E16)
+matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
+matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\s+any whitespace character, repeated at least once
spentthe literal text spent (case insensitive) \sany whitespace character
viathe literal text via (case insensitive) \s+any whitespace character, repeated at least once
Character Class[CcRrEeDdiITt]+ +matches at least one character from the set below:
Cthe literal C (6710 / 1038 / 4316) (case insensitive)
cthe literal c (9910 / 1438 / 6316) (case insensitive)
Rthe literal R (8210 / 1228 / 5216) (case insensitive)
rthe literal r (11410 / 1628 / 7216) (case insensitive)
Ethe literal E (6910 / 1058 / 4516) (case insensitive)
ethe literal e (10110 / 1458 / 6516) (case insensitive)
Dthe literal D (6810 / 1048 / 4416) (case insensitive)
dthe literal d (10010 / 1448 / 6416) (case insensitive)
ithe literal i (10510 / 1518 / 6916) (case insensitive)
Ithe literal I (7310 / 1118 / 4916) (case insensitive)
Tthe literal T (8410 / 1248 / 5416) (case insensitive)
tthe literal t (11610 / 1648 / 7416) (case insensitive)
\s+any whitespace character, repeated at least once
Character Class[CaCArRdD]+ +matches at least one character from the set below:
Cthe literal C (6710 / 1038 / 4316) (case insensitive)
athe literal a (9710 / 1418 / 6116) (case insensitive)
Athe literal A (6510 / 1018 / 4116) (case insensitive)
rthe literal r (11410 / 1628 / 7216) (case insensitive)
Rthe literal R (8210 / 1228 / 5216) (case insensitive)
dthe literal d (10010 / 1448 / 6416) (case insensitive)
Dthe literal D (6810 / 1048 / 4416) (case insensitive)
\s+any whitespace character, repeated at least once
+matches at least one character from the set below:
xthe literal x (12010 / 1708 / 7816) (case insensitive)
Xthe literal X (8810 / 1308 / 5816) (case insensitive)
0-9one character from 0 (4810) to 9 (5710)
\s+any whitespace character, repeated at least once
atthe literal text at (case insensitive) \s+any whitespace character, repeated at least once
Group 3([a-zA-Z0-9.-@\s]+) Character Class[a-zA-Z0-9.-@\s]+ +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case insensitive)
A-Zone character from A (6510) to Z (9010) (case insensitive)
0-9one character from 0 (4810) to 9 (5710)
.-@one character from . (4610) to @ (6410)
\sany whitespace character
\s+any whitespace character, repeated at least once
onthe literal text on (case insensitive) \s+any whitespace character, repeated at least once
Group 4(\d{4}-\d{2}-\d{2}:\d{2}:\d{2}:\d{2}) \d{4}a digit, repeated exactly 4 times
-the literal - (4510 / 558 / 2D16)
\d{2}a digit, repeated exactly 2 times
-the literal - (4510 / 558 / 2D16)
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
\s+any whitespace character, repeated at least once
withoutthe literal text without (case insensitive) \s+any whitespace character, repeated at least once
PINthe literal text PIN (case insensitive) \/the literal / (4710 / 578 / 2F16)
OTPthe literal text OTP (case insensitive) \.the literal . (4610 / 568 / 2E16)
+matches at least one character from the set below:
Nthe literal N (7810 / 1168 / 4E16) (case insensitive)
Othe literal O (7910 / 1178 / 4F16) (case insensitive)
Tthe literal T (8410 / 1248 / 5416) (case insensitive)
nthe literal n (11010 / 1568 / 6E16) (case insensitive)
othe literal o (11110 / 1578 / 6F16) (case insensitive)
tthe literal t (11610 / 1648 / 7416) (case insensitive)
\s+any whitespace character, repeated at least once
youthe literal text you (case insensitive) \?the literal ? (6310 / 778 / 3F16)
\s*any whitespace character, repeated any number of times
Callthe literal text Call (case insensitive) \s+any whitespace character, repeated at least once
\d+a digit, repeated at least once
.any character (except for line terminators)
\s*any whitespace character, repeated any number of times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string
i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters