re = /((?:\w| )+)(?=(?:[^`]*`[^`]*`)*[^`]*$)/
str = 'one `two three` four five `six` seven
one` two three `four five` six `seven'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end