import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+((-\\w+)|(\\.\\w+))*\\@[A-Za-z0-9]+((\\.|-)[A-Za-z0-9]+)*\\.[A-Za-z0-9]+$";
final String string = "me@too.dk\n"
+ "me.too@meee.dk\n"
+ "me,too@meee.dk\n"
+ "me.too@meee,dk\n"
+ "me-too@meee.dk\n"
+ "me.too.tt@meee.dk\n"
+ "me.too@meee.uk.dk\n"
+ "me.too@meee.co.dk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}