Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$
/
gm
Input 1
1
New
me@too.dk me.too@meee.dk me,too@meee.dk me.too@meee,dk me-too@meee.dk me.too.tt@meee.dk me.too@meee.uk.dk me.too@meee.co.dk