const regex = /(?<=\D|^)(\d{6})(?=\D|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\D|^)(\\d{6})(?=\\D|$)', 'gm')
const str = `abc12345 - no match, less than 6 consecutive digits
abc123456 - i need to match only this string and return 123456
abc1234567 - no match, more than 6 consecutive digits
abc12345678 - no match, morethan 6 consecutive digits`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}