# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^|123)(?!123).*?(?=123|$)//gm;t' <<< "abc123efg123123hij"