#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\)(?:\\\\)*(<@!?\d+>)"
Local $sString = "Valid Input String: \\<@!123>" & @CRLF & _
"Matches: <@!123>" & @CRLF & _
"" & @CRLF & _
"Invalid Input String: \\\<@!123>" & @CRLF & _
"Matches: none" & @CRLF & _
"" & @CRLF & _
"Valid Input String: <@123>test<@456>" & @CRLF & _
"Matches: <@123>, <@456>" & @CRLF & _
"" & @CRLF & _
"Invalid Input String: \<@123>test\\\<@456>" & @CRLF & _
"Matches: none"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")