import Foundation
let pattern = #"(?:(?:^|\s)(?=(?:[^\s-]*-){2})|(?!^)\G)[^\s-]*\K-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Coca-Cola Step-By-Step"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)