# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\/Amalty-WS\/)[^"\s]*\K\s(?=[^"]*")/_/gm;t' <<< "Please find the presentations:
href=\"/Portals/12/Documents/GE-Project/Amalty-WS/Joanna_POT Pb paint health econ env_RUS.pdf\">Presentation 1"