$re = '~(?:\G(?!^)|/Amalty-WS/)[^"\s]*\K\s(?=[^"]*")~m';
$str = 'Please find the presentations:
href="/Portals/12/Documents/GE-Project/Amalty-WS/Joanna_POT Pb paint health econ env_RUS.pdf">Presentation 1';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;