// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(\.\d+)?").unwrap();
let string = "Picked up JAVA_TOOL_OPTIONS: -Dmaven.ext.class.path=\"/some/path/with/name-1.3.x/foobar.jar\" -Dorg.jenkinsci.plugins.pipeline.maven.reportsFolder=\"/some/path/with/name-1.3.x/\"
javac 1.8.0_432
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}