$re = '/^(\d+\.\d+\.)(\d+)/m';
$str = '1.01.1
1.01.2
1.01.3
1.02.1';
$subst = "\g<1>0\g<2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;