$re = '~^DOCUMENTS/(?=[^\n/]*Disclosure)[^/\n]*\.pdf$~m';
$str = 'DOCUMENTS/COMPANYID.Name of Disclosure.YYYYMMDD.pdf
DOCUMENTS/COMPANYID.Some Other Document.YYYYMMDD.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);