// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?").unwrap();
let string = "-15 + 8.14i
-15+8.14j
-15 j 8,14
bad line here
+23.4-j24
-35+42.3j
+24i
+2.342j
24.523-i 432,52";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}