import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "metric(?!.*_(?:dk|none))";
final String string = "business_metric_one\n"
+ "business_metric_one_dk\n"
+ "business_metric_one_none\n"
+ "business_metric_two\n"
+ "business_metric_two_dk\n"
+ "business_metric_two_none";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}