#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?[0-9]{2,3}\)?(\s|-)[0-9]{4,5}-?[0-9]{3,4}"
Local $sString = "'00 00000000'" & @CRLF & _
"'000-000000000'" & @CRLF & _
"'000 00000-0000'" & @CRLF & _
"'00 0000-0000'" & @CRLF & _
"'(00) 0000-0000'" & @CRLF & _
"'(000) 000000000'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")