const regex = /(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:ticket(?:\\s+number)?|number)\\.?\\s?:?\\s*(\\S+)', 'gm')
const str = `ticket number A2-177653
ticket : A2-177653
number 454544 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}