re = /(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)/m
str = 'ticket number A2-177653
ticket : A2-177653
number 454544 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end