package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[Data\](?<UserName>[^\[]*)\[\/Data\]`)
var str = `[Data]kjewgjkewkj[/Data][Data] Reason: Could not find a login matching the name provided.[/Data][Data] [CLIENT: <local machine>][/Data][Binary]blah, blah, blah[/binary]"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}