import re
regex = re.compile(r".*?(?<=x)\s*?(\d*\.?\d+).*", flags=re.MULTILINE)
test_str = ("2 x 3 kg PPG etc\n"
"bob 2 x 3 kg PPG etc\n"
"1.5x1.5kgPPGetcFred\n"
"BobFred1.5x1.5kgPPGetcFred\n"
"1.5 x 2.3 kg PPG Fred Bob\n"
"bob Fred 1.5 x 2.3 kg PPG Fred Bob\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)