re = /(.*)=\"(.+)\"/m
str = 'var hq_str_s_sh000001="上证指数,3094.668,-128.073,-3.97,436653,5458126";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end