package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)for\ tomorrow[^.]*`)
var str = `The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}