const regex = new RegExp('for\\ tomorrow[^.]*', 'gm')
const str = `The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);