use strict;
my $str = 'The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.';
my $regex = qr/for\ tomorrow[^.]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";